Project Importers

JumpStart C++ for Cortex includes several GUI external-project importers, invoked under File->Import project

 

     ST CubeMX project… imports an ST CubeMX generated makefile project.

     ImageCraft JumpStart C V8 project...  imports project files from ImageCraft’s previous-version product for Cortex-M. References to JSAPI are also properly converted.

ST CubeMX Importer

CubeMX is a GUI tool from ST, which generates initialization and code snippets for the ST peripherals. It is complementary to ImageCraft’s JumpStart API (JSAPI), which approaches similar problems by providing a middleware API. The CubeMX Importer is a custom tool that takes the output of the CubeMX project generator and creates a project that is compatible with JumpStart C++ for Cortex.

 

First, use CubeMX to create a design. After the design is finished, invoke Project->Settings (in CubeMX), and then select “Makefile” in the Toolchain / IDE drop-down list:

 

 image

 

CubeMX automatically sets a default "Minimum Heap Size" and "Minimum Stack Size." If these defaults are not sufficient, you may change their values here.

 

Select the location where the generated project should reside. This should be different from your JumpStart C++ project location. Then, generate the project use the "Project/Generate Code" menu item:

 

image 

 

Now you may import the project into JumpStart C++ for Cortex.

 

In the JumpStart C++ for Cortex CodeBlocks IDE, invoke File->Import…->ST CubeMX project. This application will present the following user interface:

image 

Use the two browse buttons on the UI to select the "Makefile" generated by CubeMX, and then the project directory into which you would like the importer to import the ImageCraft JumpStart C++ project.

 

Once both the Makefile and the project folders are selected, the "Import" button will be enabled. Clicking "Import" completes the process.

 

image

 

Once finished, you may use the CodeBlocks IDE to open the resulting project file. The full path to the imported project file is in the Windows clipboard, and you may use ^V to paste the address into the File->Open browser dialog box.

 

A future release of the IDE may open the imported project immediately, saving this manual step.

 

The CubeMX project files are not required by JumpStart C++, and they may be deleted or kept around for future modification and subsequent re-import.

ImageCraft JumpStart C Project Import

The GUI and operations for this importer are similar to the ST CubeMX importer. You select the V8 project .cbp file and the new project directory, and click Import.

 

NOTE: the importer can import JSAPI and non-JSAPI V8 projects. If JSAPI is not used, then the resulting new project is C based, just like V8. However, if JSAPI is used, then the resulting new project is C++ based, as JSAPI under JumpStart C++ for Cortex relies on C++ features.